Nvidia API Mismatch

Posted by Arkham on February 19th, 2008

I’ve installed the Nvidia driver from the binary package and when I restarted, X couldn’t start and gave me a nice blue welcome screen; the X log told me that my kernel module version was 1.0-7184 and my nvidia driver version was 1.0-9755.

I tried with

sudo apt-get remove --purge nvidia-kernel-common

but the fine ubuntu hugemetapackages&&weirddependencies system suggested me to remove all my restricted kernel modules.

So I ran

sudo vi /etc/default/linux-restricted-modules-common

and added nvidia to blacklist the restricted nvidia module.

Everything works fine now, btw.

This entry was posted on Tuesday, February 19th, 2008 at 23:50 and is filed under computers. You can follow any responses to this entry through the RSS 2.0 feed. Both comments and pings are currently closed.

Tags: , ,

Comments are closed.